Help with CRAN package submission - cryptic warning

A few years ago I inherited a package that I now maintain on CRAN. I’m attempting to submit a new version (unrelated issue to remove maptools, rgdal, rgeos) but it’s not passing the automatic pre-checks, only on Debian, R devel. The log is here:

The WARNING that’s causing problems states the following:

* checking for missing documentation entries ... WARNING
Undocumented code objects:
All user-level objects in a package should have documentation entries.
See chapter ‘Writing R documentation files’ in the ‘Writing R
Extensions’ manual.

Normally, this warning would explicitly tell me which part of the documentation was missing, but this is strange because it’s only occurring on one OS/R-devel and I’ve no idea what .__global__ is referring to.

The other wrinkle is that most of the .Rd files were written by hand by the original developer, so it’s difficult to recreate the documentation short of rewriting it all with Roxygen. I’d rather not do the latter if it’s a fix that can be solved otherwise.

The source repo is here (forked from official govt repo which I’m not allowed to access): GitHub - fawda123/micromap: ORD for R micromap package development

I’m at a loss here - Google returns nothing helpful.

Wow, weird! I’m trying to see if I can reproduce the failure on R-hub builder but I’m still waiting for the results.

In any case if you decide to switch to roxygen2, GitHub - yihui/Rd2roxygen: Convert Rd to roxygen documentation can get you part of the way there (you’ll still need to add a few things, I tried it on your package and in particular quite a few @export were missing).

Update: I got PREPERROR from R-hub, so wasn’t able to reproduce the failure there. :crying_cat_face:

Thanks Maelle, apologies, I should have mentioned that the vignettes are not processed on upload to CRAN, but instead kept in the inst/doc folder as PDF. The original vignette was created as a .Rnw Sweave file and I’ve been bypassing the build checks by uploading a .tar.gz file directly to CRAN that doesn’t include the vignettes folder, just the rendered PDF in inst/doc. Another issue I’ve been avoiding since inheriting the package…

I’ve since uploaded the package to R-hub on my end, just waiting on the Debian checks.

I think I’ll try the Rd2oxygen package, I didn’t know that exists but seems to be the path of least resistence for troubleshooting.

1 Like

For anyone following this thread, I was able to get the package on CRAN after converting the .Rd files to Roxygen using the Rd2roxygen package.