R Installation Problem - Ubuntu 15.04

r
Tags: #<Tag:0x00007f656eb68610>

#1

Hello!

So I upgraded by OS from Ubuntu Precise (12.04) to Vivid (15.04) but I am unable to install R on this, after running it successfully on the older version.

I have tried various CRAN repositories in the sources.list file but none of them appear to be working. I have, however, installed other things using my command line so it definitely isn’t a network issue at my end.

I have attached a screenshot of the terminal. Please let me know where I’m going wrong.

This is what I have added in the sources.list file -

deb http://star-www.st-andrews.ac.uk/cran/bin/linux/ubuntu vivid/


#2

This may be of interest for your problem http://askubuntu.com/a/75575

Have you tried different CRAN mirrors?

The error message seems to suggest your aptkey may also need updating


#3

Solved the issue by installing the lone problematic deb file separately
from the mirrors’ link.

Also, RStudio is crashing each time I try to open it. Just installed. And
reinstalled a few times as well. Any idea why this is happening? For now, I
managed to make do with RStudio Server and access it through another
computer but I want to run RStudio as well.


#4

I don’t know about RStudio. You should ask in their support forum https://support.rstudio.com/hc/en-us


#5

RStudio Server is better and in fact, more suited to my use. Thanks anyway!